You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

rules 1019B

1234567891011121314151617181920212223242526
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Sample debian/rules that uses debhelper.
  4. # This file was originally written by Joey Hess and Craig Small.
  5. # As a special exception, when this file is copied by dh-make into a
  6. # dh-make output file, you may use that output file without restriction.
  7. # This special exception was added by Craig Small in version 0.37 of dh-make.
  8. # Uncomment this to turn on verbose mode.
  9. #export DH_VERBOSE=1
  10. %:
  11. dh $@ --buildsystem=cmake
  12. override_dh_auto_configure:
  13. dh_auto_configure -O--buildsystem=cmake -- -DCMAKE_BUILD_TYPE=Release -DGENERATE_SRS_SECRET=OFF -DCHROOT_DIR=/var/lib/postsrsd -DUSE_APPARMOR=ON -DSYSD_UNIT_DIR=/lib/systemd/system -DINIT_FLAVOR=upstart
  14. override_dh_installinit:
  15. dh_installinit -o
  16. UPSTREAM_VERSION=$(shell dpkg-parsechangelog | grep Version: | cut -d' ' -f2 | cut -d- -f1 )
  17. BASE_REVISION=$(shell git merge-base ppa master )
  18. create-orig-tar:
  19. git archive --prefix=postsrsd-$(UPSTREAM_VERSION)/ -o ../postsrsd_$(UPSTREAM_VERSION).orig.tar.gz $(BASE_REVISION)