Du kannst nicht mehr als 25 Themen auswählen Themen müssen mit entweder einem Buchstaben oder einer Ziffer beginnen. Sie können Bindestriche („-“) enthalten und bis zu 35 Zeichen lang sein.

config-debian.diff 1.6KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. --- a/config.inc.php
  2. +++ b/config.inc.php
  3. @@ -31,6 +31,16 @@
  4. ################################################################################
  5. +// Debian: This loads the automatic generated DB credentials from /etc/postfixadmin/dbconfig.inc.php
  6. +$db_config = dirname(__FILE__) . '/dbconfig.inc.php';
  7. +if (file_exists($db_config) && !is_readable($db_config)) {
  8. + die("Could not read: $db_config\n");
  9. +}
  10. +require_once($db_config);
  11. +
  12. +if (!isset($dbserver) || empty($dbserver)) {
  13. + $dbserver = 'localhost';
  14. +}
  15. /*****************************************************************
  16. * !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  17. @@ -39,7 +49,7 @@
  18. * Doing this implies you have changed this file as required.
  19. * i.e. configuring database etc; specifying setup.php password etc.
  20. */
  21. -$CONF['configured'] = false;
  22. +$CONF['configured'] = true;
  23. // In order to setup Postfixadmin, you MUST specify a hashed password here.
  24. // To create the hash, visit setup.php in a browser and type a password into the field,
  25. @@ -98,11 +108,11 @@ function language_hook($PALANG, $language) {
  26. // mysqli = MySQL 4.1+ or MariaDB
  27. // pgsql = PostgreSQL
  28. // sqlite = SQLite 3
  29. -$CONF['database_type'] = 'mysqli';
  30. -$CONF['database_host'] = 'localhost';
  31. -$CONF['database_user'] = 'postfix';
  32. -$CONF['database_password'] = 'postfixadmin';
  33. -$CONF['database_name'] = 'postfix';
  34. +$CONF['database_type'] = $dbtype;
  35. +$CONF['database_host'] = $dbserver;
  36. +$CONF['database_user'] = $dbuser;
  37. +$CONF['database_password'] = $dbpass;
  38. +$CONF['database_name'] = $dbname;
  39. // Database SSL Config
  40. $CONF['database_use_ssl'] = false;